Error Page
Incident Report for Summit Learning Platform
Resolved
Looks like we just resolved the issue! We should be all good to go now!
Posted Mar 01, 2019 - 09:02 PST
Investigating
We've heard reports that teachers are landing on our error page. We apologize for the inconvenience and are investigating this now! Thanks so much for your patience as we fix this!
Posted Mar 01, 2019 - 09:00 PST
This incident affected: Teacher App.