Site Outage
Incident Report for Summit Learning Platform
Resolved
All users should now be able to access the platform. Thank you again for your patience. If you have any questions, please reach out to our Help Desk at support@summitlearning.org.
Posted Oct 19, 2021 - 10:13 PDT
Investigating
Some users are unable to load the platform. We’re aware of the issue and are working on it urgently.

We’re sorry for the inconvenience and are working to get this fixed. We’ll update you with the latest information within the next hour.
Posted Oct 19, 2021 - 08:11 PDT
This incident affected: Student App, Teacher App, and Parent App.