Degraded Platform Performance for Some Users
Incident Report for Summit Learning Platform
Resolved
Thank you for your patience as we continued to investigate this incident. The issue is now resolved and users should be able to load the Platform as usual. If you run into any issues, please don't hesitate to reach out to support@summitlearning.org.
Posted Sep 15, 2020 - 11:21 PDT
Investigating
We have received reports that some users are experiencing an "Under Heavy Load" error, and apologize for this inconvenience. We are aware of the issue and working to restore the Platform for all users. We will update you when we have more information.

Please feel free to reach out to support@summitlearning.org if you have any questions.
Posted Sep 15, 2020 - 10:54 PDT
This incident affected: Student App, Teacher App, and Parent App.