Site outage
Incident Report for Summit Learning Platform
Resolved
All teachers should now be able to log into the platform. Thank you again for your patience. If you have any questions, please reach out to our Help Desk at support@summitlearning.org.
Posted Mar 05, 2021 - 11:04 PST
Update
We are continuing to investigate this issue.
Posted Mar 05, 2021 - 10:41 PST
Investigating
Users are unable to log into the platform. We’re aware of the issue and are working on it urgently.

We’re sorry for the inconvenience and are working to get this fixed. We’ll update you with the latest information within the next hour.
Posted Mar 05, 2021 - 10:35 PST
This incident affected: Student App, Teacher App, Parent App, and Support.