Users are unable to access the Platform
Incident Report for Summit Learning Platform
Resolved
All users should be able to access the Platform. Thank you again for your patience. If you have any questions, please reach out to our Help Desk at support@summitlearning.org.
Posted Feb 25, 2021 - 08:39 PST
Investigating
Users are unable to log into the Platform. We are investigating immediately and will provide updates within the next hour.
Posted Feb 25, 2021 - 08:19 PST
This incident affected: Student App, Teacher App, Parent App, and Support.