Investigating Platform Performance
Incident Report for Summit Learning Platform
Resolved
Thank you for your patience as we've investigated the site outages from November and have taken steps to mitigate any future occurrences. We have resolved the incident, and our team has made -- and will continue to make -- substantial improvements to the platform to prevent future issues.
Posted Dec 10, 2019 - 13:57 PST
Update
Over the past few days, we have not seen issues with the platform's performance. While we are still looking into the root cause, we have made and will continue to make improvements to enhance our platform stability.

Thank you for your patience, and we will continue to update you on our progress as we get closer to fixing the root cause.
Posted Nov 19, 2019 - 16:21 PST
Update
While we have not seen any issues today with platform performance, we are continuing to investigate the root cause of the previous outages. We are still closely monitoring the platform and improving platform stability as we continue to investigate.

We will continue to update StatusPage as we make further progress towards mitigating the root cause.
Posted Nov 18, 2019 - 16:10 PST
Update
Platform online, investigating root cause— We are closely monitoring the platform and while we have not seen any issues this morning, we are still investigating the root cause of the previous outages. We're continuing to investigate and improve platform stability.

If you have any problems accessing the platform, please contact us at support@summitlearning.org.
Posted Nov 15, 2019 - 12:25 PST
Update
We are continuing to investigate the root cause and have implemented some fixes to improve the stability of the platform. Some users may have experienced some interruptions this morning from 9:38–9:53 am PT where they were unable to load pages or experienced slow page loads. Thank you again for your patience. We will continue to monitor and make improvements to stabilize the platform.

If you have any problems accessing the platform, please contact us at support@summitlearning.org.
Posted Nov 14, 2019 - 10:40 PST
Update
While we have not yet resolved the root cause of the issue, our engineers have been working day and night to identify, analyze, and fix the root cause of the issue. We will continue to investigate and implement updates until the platform is fully restored.

While we diligently work on restoring the platform, we want to help you plan your school days and provide the best support possible. We have identified a pattern in the platform outage that begins at approximately 8 a.m. PST/11 a.m. EST and lasts for approximately one to two hours. We anticipate the outages will continue until we fix the root cause, and ask that you make the necessary adjustments to your plans to keep work going in the classroom.

We sincerely apologize for the disruption to you and your students and will continue to provide updates here as we work towards resolution.
Posted Nov 13, 2019 - 16:00 PST
Update
We have received reports that some of our users are still having errors loading the platform. We know how much work goes into planning for the school day, and that not being able to access the platform disrupts your plans. Our engineers are investigating the root cause and making progress to resolve the issue.

We will update you later today on the status of the platform here. If you have any questions, please reach out to us at support@summitlearning.org.
Posted Nov 13, 2019 - 08:12 PST
Update
While we have not experienced any further outages since this morning, we are still in the process of identifying the root cause. Our team will continue to actively monitor the site overnight and tomorrow morning as we proceed with our investigation. We know this interrupted your school day, and we appreciate your patience as we make updates to improve the platform.

If you have any questions, please reach out to us at support@summitlearning.org.
Posted Nov 12, 2019 - 14:53 PST
Update
The platform experienced another 'Under Heavy Load' error this morning. We understand the impact of these issues in your classrooms and apologize for the inconvenience. You should now be able to access the platform. Please make sure to refresh your page.

We appreciate your patience while some areas of the platform continue to refresh. You may experience delays with the platform’s grading pages right now, and we want to reassure you that grades are still being saved. All grades will be updated after the grading function refreshes completely by tomorrow morning. Ensuring the accuracy of student data is extremely important to us.

We're still investigating the issue that caused the error so that we can ensure the platform is stable going forward. If you have any questions, please reach out to us at support@summitlearning.org.
Posted Nov 12, 2019 - 11:20 PST
Investigating
We have similar reports from last week about an "Under Heavy Load" error. We apologize for this inconvenience and are actively working to restore the platform asap. We will update you when we have more information.
Posted Nov 12, 2019 - 09:03 PST
This incident affected: Student App, Teacher App, and Parent App.