Website Under Heavy Load Error
Incident Report for Summit Learning Platform
Resolved
As of today, we are confident that we have resolved the primary cause of the intermittent site outages. To be certain, our engineering team will diligently observe the site over the next few days. We are optimistic that this issue has been fixed.

Building on the work we've done over the past week, we are doubling down on our efforts to reinforce our infrastructure so we can improve the platform's reliability in the long-term and prevent any future incidents. Some of these updates might result in some temporary bugginess in the platform, but our engineering team is prepared to address those issues quickly if they arise.

We are appreciative of your patience, partnership, and understanding over the past week. We are deeply committed to delivering the best learning experience to you and your students - it’s our purpose.

Thank you.
Posted 5 days ago. Sep 10, 2019 - 09:12 PDT
Monitoring
Over the weekend, we identified and removed the changes we believe caused the intermittent site outages last week, and added in new fixes to prevent future Platform instability.

In order to make sure those fixes worked, our team is monitoring the site closely, and we are ready to address any unforeseen issues if they arise.

Thank you for your patience, resilience, and understanding.

If you experience an error message while using Summit Learning, please let us know via support@summitlearning.org.
Posted 6 days ago. Sep 09, 2019 - 08:49 PDT
Update
Yesterday evening, we released a limited set of updates to help improve our site reliability. Despite these updates, some users still were unable to use the platform today from 8-9:30 am PST.

We will be releasing technical fixes soon that will fix the immediate cause of the site issues from this week, and we will continue debugging the site over the weekend so the site is ready for Monday.

Thank you for your patience, and we will continue to update this page as we have updates.
Posted 9 days ago. Sep 06, 2019 - 15:25 PDT
Update
Thank you for your patience as we continue to investigate this issue. We were able to mitigate several avenues that were causing issues with our site infrastructure, but we are still looking into a few other potential issues that are impacting our site's performance.

In the interim, our team is keeping a close eye on our site, and will be doing our best to work toward resolving this issue.
Posted 10 days ago. Sep 06, 2019 - 07:00 PDT
Update
We are seeing that some users are encountering the error again today. Our team is aware and working to restore Platform access for anyone affected. We'll continue to update you on our progress.
Posted 10 days ago. Sep 05, 2019 - 08:45 PDT
Update
Most users should now be able to access the platform, but our team is still investigating the root cause of this issue. We are identifying which parts of our infrastructure need to be reinforced in order to best meet our increased traffic, and we will be working toward making those improvements as soon as we can.

We will continue to update StatusPage as we get closer to resolving the root issue. For now, if you run into errors, please try refreshing the page. If that does not resolve the issue, do not hesitate to reach out to support@summitlearning.org.
Posted 11 days ago. Sep 04, 2019 - 11:06 PDT
Investigating
We are continuing to investigate this issue. Thank you for your patience while we continue towards a solution, and we hope to have an update for you soon.
Posted 11 days ago. Sep 04, 2019 - 09:05 PDT
Identified
We are noticing that some users are seeing the error again this morning when trying to access the Platform. Our team is working on a fix and we hope to get everything working soon! We apologize for the inconvenience.
Posted 12 days ago. Sep 04, 2019 - 07:35 PDT
Monitoring
Users should now be able to access the Platform without an issue. We are continuing to monitor the site to make sure this doesn't happen again. Thank you for your patience! If you are continuing to have trouble, please reach out to us at support@summitlearning.org.
Posted 12 days ago. Sep 03, 2019 - 13:28 PDT
Investigating
Some users are running into an error that says the website is "under heavy load." We are aware of the issue and looking into it. In the meantime, please wait a few minutes and try refreshing the page.
Posted 12 days ago. Sep 03, 2019 - 12:04 PDT
This incident affected: Student App, Teacher App, and Parent App.