Investigating Inability to Access Project Pages (2018-19)
Incident Report for Summit Learning Platform
Resolved
The issue has been resolved and access to 2018-19 project pages is now fully available. If you see any additional issues, please contact our Help Desk: support@summitlearning.org
Posted Jun 08, 2018 - 17:21 PDT
Identified
We are currently investigating and pushing out a fix.
Posted Jun 08, 2018 - 17:00 PDT
This incident affected: Teacher App.